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This is a quick introduction guide to the Scribble Artist action set. You may also want to watch the 

video tutorial. 

The Action set was tested on Adobe ​Photoshop CS6, CC 2017, CC and 2018,​​ in both English and 

Spanish versions. The actions are designed to work with any language; however, you will have to 

rename the two initial layers in English. Details are in the next sections. 

 

ACTION SET FEATURES  

● Made with hand-drawn brushes and patterns.  

● Easy ink color control.  

● Custom pen brush makes each image unique.  

● Well-organized layer structure that is color-coded and grouped.  

● Textures to simulate paper.  

● Each consecutive playback gives a different result.  

● A total of 1 action, 30 brushes, and 5 patterns.  

● Tested on images up to 5,000 pixels.  

● Video tutorial and detailed text guide. 
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FIRST STEPS 

 

__________________________________________________________________________________ 

 

INSTALLATION 

 

1.​​ Open Photoshop and the Actions panel (Window>Actions). On the Actions panel, click the menu 

icon at the top-right corner, then select Load Action and select the action file ​Scribble Artist - Action 

from wherever you downloaded it to. 

 

2.​​ To install the brushes and patterns, go to menu Edit>Presets>Presets Manager. In the Presets 

Manager panel, select ​Brushes ​​as​ Preset Type,​​ click Load, and select the file ​Scribble Artist - 

Brushes​​. You can use the first three brushes manually; the rest will be used automatically by the 

action. 

 

3.​​ Still in the Presets Manager panel, change the ​Preset Type​​ to ​Patterns​​ and load the file ​Scribble 

Artist - Patterns​​. 
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IMAGE REQUIREMENTS 

 

1.​​ Open the image you want to work with and go to Image>Mode. Make sure the image is in ​RGB/8 

bit​​ color mode. 

 

The next two points are important because they will affect substantially the final result of the action. 

 

2.​​ The action works best on images with good to high resolution. It was tested on images up to 5,000 

pixels, make sure your image has a good resolution.  

On low-resolutions, the final effect will be less dense and detailed, with thicker strokes.  

On high-resolution images, the action gives a more detailed result and thinner strokes.  

 

3.​​ The action will concentrate its pen strokes on shadowy areas. If the source image has a lot of dark 

areas or is underexposed, the final result of the action will be very dark and detailed. If the source 

image is overexposed or mostly white, the outcome will have very few strokes and details. 

An image with a balanced lighting works well. 

 

For tips on tweaking the source image to get better results, see the “Quick Customization” section. 
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BEFORE PLAYING THE ACTION 

 

1. ​​The source image should be the only layer in your file, and that layer should be locked and named 

Background​.  
To set the layer as ​Background, ​select it, then go to menu Layer>New>Background from Layer. 

 

2.​​ Create a new layer above it and rename it ​mask​. This layer name must be ​all lower-case letters​​. 
 

3.​​ Select the layer named​ mask​, open the Brushes panel (press F5 on the keyboard), and then paint 

over the area you want to isolate with the Brush tool. (The action will turn this painted area into a 

scribbled sketch.) 

 

Depending on the edge hardness of your brush, the action yields slightly different results. You can 

begin with the ​Scribble Hard Brush ​​included with the action.​ ​​Later, you can experiment with soft 

brushes and also mix the two types. 

 

If you prefer, you can isolate areas in the layer named ​mask​ with a tool other than a brush—for 

example, the Wand, Lasso, or Pen. 

 

4.​​ At this point, there should be only two layers in the file, and they should be named ​mask​ ​​and 

Background​. 
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PHOTOSHOP IN LANGUAGES OTHER THAN ENGLISH 

 

The only requirement when using Photoshop in languages different than English is to rename the 

first two layers to the English words ​Background​ and ​mask​. 
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HOW TO USE THE ACTION 

 

1.​​ Open Photoshop’s Actions panel. Select the ​SCRIBBLE ARTIST​​ action and click the triangular Play 

icon at the bottom of the panel. At the beginning of the playback, a message will appear: 

 

In Photoshop’s Options bar, the Brush tool’s Opacity and Flow parameters must now be set to 100%. 

If they are, click Continue. If they are not, click Stop, correct the two values and then click the 

action’s Play button again. 

 

2. ​​The action will take from two to four minutes, depending on the resolution of the image and your 

machine, and will generate many layers. 

 

3.​​ When the playback finishes the message ​Render Completed​​ will appear. Click Continue. 



4.​​ There are now many opened groups and layer styles in the Layers panel. To quickly organize it, 

hold ALT (OPTION on Mac) and click the arrow of the group named ​Scribble Artist – OUTPUT.​ ​​Then 

release the ALT/OPTION key. When you open the group, you’ll see that all of its layers and groups 

are organized. 

 

5. ​​The result of the action isn’t always perfect, but it is a great starting point that you can quickly 

customize in the Layers panel. See the “Quick Customization” section of this guide for details. 
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LAYER STRUCTURE 

 

Let’s take a quick look at the layers structure. Inside the ​Scribble Artist - OUTPUT​​ group, there are 

four sub-groups. The group named ​Main​ has important subgroups containing all the parts drawn by 

the action: 

 

- Post FX 

- Paper Textures 

- Ink Color 

- Outlines & Extras 

- Outer Scribbles 

- Scribbles 

- Sketches 

- Paper Color 

 

To see what each group does, hide the group one by one, starting from the top. 

 

TIP​​: It's a good practice to close each group once you’ve finished editing it. Some of them contain 

many layers and sub-groups, and focusing on only one at a time helps to keep your Layers panel 

organized.  
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QUICK CUSTOMIZATION 
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With a basic understanding of the essential parts of the Layers tree and how to customize those 

parts, you will be able to easily edit the initial results of the action and create many variations of the 

effect. 

 

FIRST PLAYBACK:​​ If the result of the action is too dark and messy for you, simply hide some of the 

scribbled layers to make the image brighter and cleaner. It should look a bit messy because that’s 

what the style is about, but sometimes it can be too much. 

 

THE SOURCE IMAGE:​​ Resolution and brightness of the source image greatly affect the result.  

You can tweak the source image if necessary; for example, a simple Levels adjustment layer (Ctrl+L 

on Windows and Cmd+L on the Mac) may be enough. Just making the midtones of the image darker 

or brighter will yield different results. 

Before you tweak the source image, save a JPG preview of the first playback for comparison. Then 

delete the ​OUTPUT​​ group, select the layer of the image, and modify it. Next, select the action and 

play it again. 

 

THE MASK: ​​The way shapes and edges in the layer named ​mask​ are painted also have a significant 

effect on the final image; for example, a lot of edges will generate more scribbles, while a more 

rounded and smooth mask layer will generate fewer scribbles. As you experiment with the action, 

try different shapes and edges: hard, soft, and a combination of both. 

 

For a detailed description of each layer, check the separate ​Step-by-Step guide​​. 
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FX GROUP 

This group is the first thing you’ll want to edit after the playback. It acts as a control panel in which 

you can quickly equalize the result of the action. The two ​Reveal​​ layers are especially powerful, 

giving you a lot of control over the final effect. Balance their transparency using the Fill parameters 

and try them also in Screen blending mode. 

 

With the layer ​Control,​​ you can manually tune shadows, midtones, and highlights of the scribbled 

effect. To use this simple Levels adjustment layer, you first must mute the mask channel of the layer 

Reveal Highlights​​ by Shift-clicking on the mask channel. 

 

The next three layers add some details to the effect. ​Add Shadows​​ not only darkens the image but 

also contributes with some details. Use the Fill values on these layers to make them more or less 

visible. You can also duplicate them by pressing Ctrl+J on Windows or Cmd+J on Mac.   



To highlight and enhance important areas of an image, such as a subject’s eyes, you could duplicate 

Bright Details​​ and invert the mask channel of the duplicated layer to basically hide it by selecting it 

and pressing Ctrl+I in Windows or Cmd+I on Mac.  

Then you could reveal the wanted area painting with a white brush. 
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HOW TO EDIT ALL THE DRAWN LAYERS 

The majority of the layers generated by the action contain scribbles, sketches, and strokes. There are 

a lot of them, as almost 90% of the tree is made of drawn layers. But once you know how to edit just 

one, you’ll be able to customize all the others in the same way. In the separate ​Step-by-Step Guide 

you’ll find a detailed description of these ​Basic Editing Methods​​, but here is a quick summary: 

 

● Hide and unhide layers to achieve different effects.  

● Use the opacity/fill parameters to adjust their transparency  

● Each layer has a mask channel you can use to hide or reveal parts of it. If an area of the 

subject is too dense and dark, by painting the mask you can hide a selected number of 

scribbles to make the area clearer.  

● Duplicate layers and move them in the Canvas. Or use the Transform tool (Ctrl+T in 

Windows, Cmd+T on Mac) on a duplicated layer to move, scale, and rotate it. 
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SCRIBBLES GROUP 

The blue ​SCRIBBLES​​ group is the most important of the set. Inside the subgroups​ Patterns, Shadows, 

Midtones, ​​and ​Highlights​​ are all the layers that create the scribbled effect. Edit them using the basic 

editing methods. Patterns and Shadows both contribute to create the darker areas of the image and 

should be edited in parallel. 

 

By modifying these four blue groups, you can entirely change the result of the action and achieve 

many different results. The group Midtones, for example, has the most chaotic scribbles, so simply 

by hiding some of these layers, you’ll have a cleaner result. 

 

Note that Midtones and Highlights have grey mask channels, which you can double-click to edit their 

properties. Using the parameter ​Density,​​ it is possible to decide how much all the layers of these 

groups will be visible outside of the subject. Basically, it’s a filtered Opacity parameter that helps to 

make the subject easier to read. 
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INK COLOR 

With this layer, it’s possible to change the ink color of the pen: Simply double-click the thumbnail of 

the layer to select a different color. Hiding this layer will make a black ink effect. 

  



 

SCRIBBLE PEN BRUSH 

The first brush of the set, ​Scribble Pen Brush​​, is a custom brush that simulates a ballpoint pen.  

It has pressure sensitivity and it works at it’s best with graphical tablets. 

Use it with a black color to create new strokes and patterns on any of the already drawn layers and 

on new dedicated layers. If you want to paint on a new layer, make sure it’s positioned under the 

layer ​Ink Color​​ in the layers panel; otherwise, it will not be affected by the selected color. 

 

PAPER 

You can also customize the Paper. To change the color of the paper, select one of the presets in the 

group ​Paper Color​​, or choose a custom color by double-clicking the thumbnail of one of those layers. 

Inside ​Paper Texture​​ there are four textures that you can combine using their Fill parameters to 

achieve different kinds of paper effects. 

 

POST FX 

The layers inside this group give the final touches to the image. The layer ​Levels​​ can be very useful 

after a customization or when choosing a paper color different by the default one: Double-click its 

thumbnail and click the ​Auto​​ button to apply an auto-contrast and quickly rebalance the image.  

 

The other layers of the group are very easy to edit; hide and unhide them to see how they’re 

contributing. Each one is described in detail in the ​Step-by-Step Guide​​. 
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